azure scheduled query rules ARM template
Type of issue
Typo
Reference command name
az deployment group create --name XXX --resource-group XXX --template-file XXX.json --parameters XXX.json --mode Incremental --output json
Overview
This issue is similar to https://github.com/Azure/azure-cli/issues/27138.
When using operator: Equals as specified in the Microsoft ARM documentation, the request fails with the error: Requested value 'Equals' was not found.
Feedback
Upon investigation, it appears that the correct value should be Equal, as confirmed by inspecting the actual network request on the portal. This discrepancy between the documentation and expected value leads to confusion and failed deployments.
{
"properties": {
"criteria": {
"allOf": [
{
"query": "AzureActivity | where TimeGenerated > ago(1h) | where OperationNameValue contains \"Microsoft.ContainerService/managedClusters/agentpools/write\" | where ActivityStatusValue == \"Started\"",
"timeAggregation": "Count",
"dimensions": [],
"resourceIdColumn": "",
"operator": "Equal",
"threshold": 1,
"failingPeriods": {
"numberOfEvaluationPeriods": 1,
"minFailingPeriodsToAlert": 1
}
}
]
}
}
}
After digging into the CLI extension where operator conversion is performed, it seems like the correct operator to be using is Equal instead of Equals.
https://github.com/Azure/azure-cli-extensions/blob/main/src/scheduled-query/azext_scheduled_query/grammar/scheduled_query/ScheduleQueryConditionValidator.py
I have attempted to change the operator to Equal inside the ARM template, and the deployment is able to go through successfully. I have yet to test both terraform and bicep template, but it might be worth updating the mentioned attribute in both documentation as well.
Page URL
https://learn.microsoft.com/en-us/azure/templates/microsoft.insights/2022-06-15/scheduledqueryrules?pivots=deployment-language-arm-template
Content source URL
No response
Author
No response
Document Id
No response
Thank you for opening this issue, we will look into it.
Thanks for the feedback! We are routing this to the appropriate team for follow-up. cc @Azure/deployments-owners.